Rock & Roll para Muñones

Lecciones de guitarra gratuitas, para muñones como tú.

PROBLEMA LATENCIA - SCARLETT 2i4

14 Ene 2015 01:20 - 14 Ene 2015 01:36 #1 por porteador


  • Mensajes: 80

  • Género: Hombre
  • Fecha de Nacimiento: 19 Jun 1969

  • Buenas noches, a ver si me podéis echar un cable los que entendáis del tema.

    Resulta que me he pillado una interfaz scarlett 2i4 y me he descargado el Ablelton 9 live que viene con su licencia. A base de leer en la ayuda he podido hacer que suene, pero noto algo de latencia o retardo en la respuesta desde que toco la cuerda hasta que la oigo. Entiendo que esto debe ser normal ¿no? .

    No se si hay manera de eliminar o reducir este efecto pues a la hora de grabar/escuchar es molesto. Adjunto una captura de la configuración y si entendéis del tema me guiáis. Os estaré eternamente agradecido.

    Según el programa el buffer del tamaño de entrada y salida hay que ajustarlo al mínimo que sea posible sin que el sonido se oiga con taps o ruido. Así lo he hecho, y me sale una latencia total de 43 ms.

    Un saludote
    Adjuntos:
    Última Edición: 14 Ene 2015 01:36 por porteador. Razón: Insertar imagen

    Por favor, Identificarse o Crear cuenta para unirse a la conversación.



    14 Ene 2015 09:02 #2 por jebiman


  • Mensajes: 144

  • Género: Hombre
  • Fecha de Nacimiento: 13 Oct 1983
  • Respuesta de jebiman sobre el tema PROBLEMA LATENCIA - SCARLETT 2i4
    Buenas!

    Yo hace poco me pillé una Scarlett 2i2, y al principio, con los drivers que venían, al configurar la tarjeta, también tenía una latencia exagerada. Leyendo y leyendo, leí que era mejor usar los drivers Asio4all generales, así que así lo probé, y mejoró bastante.

    Luego puedes ajustar si no recuerdo mal el buffer de entrada. Cuanto más grande sea el buffer, menos latencia, pero peor calidad.

    Más tarde me dí en las narices con el problema de que cualquier procesador de audio que usara en mi pc para modificar la señal de entrada (amplitube y esas cosas), me aumentaba muchísimo la latencia también, así que al final acabé grabando directamente el sonido según sale del amplificador o pedalera que tengo, y ahora ya sin problema.

    No sé si me he explicado bien, pero bueno, y así es como solucioné mi problema!! Ahora me escucho con una latencia mínima y puedo grabar a gusto (creo que tengo una latencia de 11ms la última vez que lo miré)

    Espero te sirva de algo, también soy nuevo en estas cosas. Por cierto, uso cubase 5.

    Free your Bird!
    El siguiente usuario dijo gracias: porteador

    Por favor, Identificarse o Crear cuenta para unirse a la conversación.

    14 Ene 2015 09:11 #3 por porteador


  • Mensajes: 80

  • Género: Hombre
  • Fecha de Nacimiento: 19 Jun 1969
  • Respuesta de porteador sobre el tema PROBLEMA LATENCIA - SCARLETT 2i4
    Bueno, he estado buceando por internet y leyendo el manual del focusrite :blush: y es lógico y normal que esto suceda. Evidentemente la latencia es el tiempo que pasa desde que tocas una cuerda hasta que escuchas el sonido a través de los altavoces del PC.

    Esto se resuelve fácilmente. El aparato en cuestión tiene una salida para los auriculares y una opción que es "DIRECT MONITOR" que lo que hace es que el sonido te lo entrega directamente a los auriculares y así no hay latencia.

    Lo que a mi me estaba pasando era que a falta de un adaptador de Jack de 3,5mm a 6,35mm pues conectaba directamente al PC y por tanto la latencia se escucha. Así que voy a comprar un adaptador y a olvidarme del retardo.

    Respecto del Software, no lo tengo claro todavía. Seguiré informándome para poder ajustar al mínimo el retardo. No se que valor poner en la compensación error de controlador, ni siquiera si he de poner algún valor, así que lo dejaré a cero y seguiré informándome.

    Perdón por el ladrillo. Espero que le pueda servir a algún muñón que como yo no se haya leído bien antes (cosas de tíos :lol: ) las instrucciones.

    Saludos.

    Por favor, Identificarse o Crear cuenta para unirse a la conversación.

    14 Ene 2015 09:25 #4 por jebiman


  • Mensajes: 144

  • Género: Hombre
  • Fecha de Nacimiento: 13 Oct 1983
  • Respuesta de jebiman sobre el tema PROBLEMA LATENCIA - SCARLETT 2i4
    Ah, claro, pensé que estabas conectando los cascos/altavoces a la salida del scarlett, si lo conectabas al PC entonces ya es imposible grabar mientras escuchas.

    Aún así, desde la tarjeta, tendrás también latencia, dependiendo ya de si tu PC tiene capacidad suficiente para procesar la señal de entrada y amplificarla, y de los drivers que uses (mi PC es guachipein, por eso altero la señal con el ampli antes de mandarlo a la tarjeta, para que el PC trabaje lo menos posible).

    Asegurate de configurar bien el programa que utilizas, para decirle que la entrada es la del focusrite, y la salida también, e intenta tener deshabilitada la tarjeta de sonido de tu PC mientras grabas, pues pueden entrar en conflicto.

    Un saludo!

    Free your Bird!
    El siguiente usuario dijo gracias: porteador

    Por favor, Identificarse o Crear cuenta para unirse a la conversación.

    14 Ene 2015 11:23 - 14 Ene 2015 12:28 #5 por porteador


  • Mensajes: 80

  • Género: Hombre
  • Fecha de Nacimiento: 19 Jun 1969
  • Respuesta de porteador sobre el tema PROBLEMA LATENCIA - SCARLETT 2i4

    jebiman escribió: Asegurate de configurar bien el programa que utilizas, para decirle que la entrada es la del focusrite, y la salida también, e intenta tener deshabilitada la tarjeta de sonido de tu PC mientras grabas, pues pueden entrar en conflicto.

    Un saludo!


    Pues lo que me comentas del programa, la entrada la tengo con el focusrite, pero la salida la tengo por los altavoces, tendré que cambiarlo. los sonidos del sistema los tengo anulados, pero no he deshabilitado la tarjeta. Lo tendré en cuenta ¡¡Gracias!!

    Edito:

    He encontrado unos magníficos artículos en esta página que explican todo sobre latencia y cual es el límite aceptable para el oido humano.
    Última Edición: 14 Ene 2015 12:28 por porteador. Razón: adjuntar web

    Por favor, Identificarse o Crear cuenta para unirse a la conversación.



    14 Ene 2015 13:52 #6 por Sanxzz


  • Mensajes: 284

  • Género: Desconocido
  • Fecha de Nacimiento: Desconocido
  • Respuesta de Sanxzz sobre el tema PROBLEMA LATENCIA - SCARLETT 2i4
    Yo uso la Scarlett 2i4 con los drivers de fábrica en el Ableton Live 9 y con que configures la salida a través de la interfaz debería ser suficiente para grabar sin retardo.

    El direct monitor sólo te entrega el sonido que entra a la interfaz, directamente. Si usas amplitube o algo así no te sirve, ya que buscas el sonido que vuelve del ordenador. Sólo te saldría el sonido en limpio de la guitarra.

    Aún así, seleccionando el sonido de vuelta del ordenador, no tengo ningún tipo de latencia con los drivers de fábrica.
    El siguiente usuario dijo gracias: porteador

    Por favor, Identificarse o Crear cuenta para unirse a la conversación.

    14 Ene 2015 15:09 #7 por jebiman


  • Mensajes: 144

  • Género: Hombre
  • Fecha de Nacimiento: 13 Oct 1983
  • Respuesta de jebiman sobre el tema PROBLEMA LATENCIA - SCARLETT 2i4
    Un pequeño apunte. Si usas amplitube o algún simulador similar (como los plugins que vienen con el cubase), sí que te saca el sonido procesado por la salida de la tarjeta. No sé si es por el tipo de configuración que tengo puesta, pero vamos, que sale, aunque tiene un retardo de pelotas, porque la señal se procesa antes de salir.

    Puede que la tenga mal configurada o algo, pero por los cascos yo escucho todo lo que se está reproduciendo en el cubase, si sólo me escuchara a mí en limpio, no podría grabar....

    Free your Bird!
    El siguiente usuario dijo gracias: porteador

    Por favor, Identificarse o Crear cuenta para unirse a la conversación.

    14 Ene 2015 16:18 #8 por porteador


  • Mensajes: 80

  • Género: Hombre
  • Fecha de Nacimiento: 19 Jun 1969
  • Respuesta de porteador sobre el tema PROBLEMA LATENCIA - SCARLETT 2i4
    Gracias sanxzz y jebiman, lo que voy a intentar es pasar la señal del amplificador directamente a la scarlett, así no me tengo que preocupar de los preset del amplificador en el Ableton y grabar ya con el sonido de mi ampli directamente. Aprovecho la salida de auriculares del fender para llevarla a la entrada del scarlett. No se que tal funcionará, pero lo voy a probar a ver que tal.

    Saludos.

    Por favor, Identificarse o Crear cuenta para unirse a la conversación.

    14 Ene 2015 19:13 #9 por frank63


  • Mensajes: 624

  • Género: Hombre
  • Fecha de Nacimiento: 27 Nov 1963
  • Respuesta de frank63 sobre el tema PROBLEMA LATENCIA - SCARLETT 2i4
    Creo que tienes mal configurado el dispositibo del controlador, en Preferencias.

    Tu tienes elegido, MME/Direct X. Y asi no te va a funcionar bien.

    Tienes que elegir Asio, en el dispositivo del controlador.

    Y luego prueba a conectar los altavoces que utilzas a la salida de la interface Scarlett,

    Si no te funciona bien mandame un privado y te lo explico mejor...

    Ademas fijate que tienes signos de Admiracion, en negro y en grande, en preferencias, mientras te salgan esos signos , algo estas haciendo mal, te lo digo por experiencia...

    Por favor, Identificarse o Crear cuenta para unirse a la conversación.

    14 Ene 2015 22:13 #10 por sergioxmc


  • Mensajes: 511

  • Género: Hombre
  • Fecha de Nacimiento: 09 May 1978
  • Respuesta de sergioxmc sobre el tema PROBLEMA LATENCIA - SCARLETT 2i4
    Prueba, además, a subir la frecuencia de muetreo a 48KHz...a mi me va mejor así, aunque yo uso el guitarlink ese...

    Saludos.
    El siguiente usuario dijo gracias: porteador

    Por favor, Identificarse o Crear cuenta para unirse a la conversación.



    Tiempo de carga de la página: 0.287 segundos
    ×